viernes, 26 de diciembre de 2008

plugin java firefox en ubuntu 64 bits por fin!! (buho21)

Hola, por fin se a liberado la opcion de 64 bits por parte de java para el explorador. con la cual se podra disfrutar de java en todo su explendor. los pasos son los siguientes.

Descargar el bin desde

https://jdk6.dev.java.net/6uNea.html o dale clik al sigueinte enlace Linux x64 JRE

luego hacemos
cd /opt
sudo mkdir java
cd java

luego el archivo descargado lo copiamos dentro del directorio de java creado anteriormente

Despues ejecutamos el binario con

sudo bash jre-6u12-ea-bin-b03-linux-amd64-22_dec_2008.bin

Nota: la version del archivo esta cambiando constantemente, asi que debes de poner el nombre correcto del que hallas bajado.

luego hacemos lo siguiente

sudo update-alternatives --install "/usr/bin/java" "java" "/opt/java/jre1.6.0_12/bin/java" 1
sudo update-alternatives --set java /opt/java/jre1.6.0_12/bin/java


y por ultimo instalamos el plugin de java en firefox

mkdir ~/.mozilla/plugins
ln -s /opt/java/jre1.6.0_12/lib/amd64/libnpjp2.so ~/.mozilla/plugins/

Reiniciamos nuestro firefox y tenemos java!!!! y para los que usan buho21 solo descargamos el achivo ajedrez jnlp y luego le damos abrir con otra aplicacion y nos vamos al sistema de archivos/opt/java/jr../javaws/javaws y con esto le damos abrir y vuala!! ya tenemos buho21 en nuestro ubuntu hardyde 64 bits!!!!

6 comentarios:

  1. Perfecto me ha funcionado a la primera, muchas gracias!!!

    ResponderEliminar
  2. A mi me sigue sin funcionar...
    Tengo Intrepid Ibex.

    ResponderEliminar
  3. Me funciona, muchas gracias

    Pero que sucede con las aplicaciones que usan java como limeware?

    ResponderEliminar
  4. Lo que pasa que este tutorial esta probado en ubuntu hardy de 64 bits, y si tienes intrepid debe ser de una forma diferente.. y con las aplicaciones como limewire recordemos que todavia no existe soporte por parte de los creadores de limewire para procesadres de 64 bits :-(, aunque existen algunos tutos por internet para poder echarlo a andar, solo que no he tenido tiempo de revisarlo.. saludos

    ResponderEliminar
  5. Me ha funcionado a la primera (sustituyendo el bin por el más actualizado), en Ubuntu 9.04.
    Muchísimas gracias.

    ResponderEliminar